[Webkit-unassigned] [Bug 161484] GL_PACK_ROW_LENGTH should be optional

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 1 04:54:14 PDT 2016


--- Comment #1 from memeka <mihailescu2m at gmail.com> ---
for my GPU (mali 768) i found GL_PACK_ROW_LENGTH is a GLES3 function

in GLES3/gl3.h:

#ifndef GL_ES_VERSION_3_0
#define GL_ES_VERSION_3_0 1
typedef unsigned short GLhalf;
#define GL_READ_BUFFER                    0x0C02
#define GL_UNPACK_ROW_LENGTH              0x0CF2
#define GL_UNPACK_SKIP_ROWS               0x0CF3
#define GL_UNPACK_SKIP_PIXELS             0x0CF4
#define GL_PACK_ROW_LENGTH                0x0D02


but maybe it should be replaced by a GLES2 function for better compatibility.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160901/72834979/attachment.html>

More information about the webkit-unassigned mailing list