[Webkit-unassigned] [Bug 163163] New: Rename CryptoAlgorithmParameters to CryptoAlgorithmParametersDeprecated
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Oct 7 19:36:29 PDT 2016
https://bugs.webkit.org/show_bug.cgi?id=163163
Bug ID: 163163
Summary: Rename CryptoAlgorithmParameters to
CryptoAlgorithmParametersDeprecated
Classification: Unclassified
Product: WebKit
Version: WebKit Nightly Build
Hardware: Unspecified
OS: Unspecified
Status: NEW
Severity: Normal
Priority: P2
Component: WebCore Misc.
Assignee: webkit-unassigned at lists.webkit.org
Reporter: jiewen_tan at apple.com
For the current CryptoAlgorithmParameters, it is a subclass of RefCounted<> which is non copyable. However, in order to work with the code generator to generate binding to convert a dictionary type to the corresponding C++ native type, it requires the native type copyable. Given the fact that many places in the old WebkitSubtleCrypto interface requires the CryptoAlgorithmParameters to be RefCounted, it will be hard to get rid of RefCounted<> directly. Therefore, I come out with the idea of renaming it to CryptoAlgorithmParametersDeprecated and have a new CryptoAlgorithmParameters for the new SubtleCrypto interface. BTW, the main reason for doing this is that I really want to use the code generator to generate corresponding binding codes as it will be more readable and easier to maintain. P.S. WebkitSubtleCrypto does the conversion by itself.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161008/726aa389/attachment.html>
More information about the webkit-unassigned
mailing list