[Webkit-unassigned] [Bug 162967] New: [Readable Streams API] Align function names with spec

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 5 05:35:57 PDT 2016


            Bug ID: 162967
           Summary: [Readable Streams API] Align function names with spec
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Local Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebCore Misc.
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: romain.wkt at gmail.com

Readable Streams API implementation has globally been aligned with latest spec, but functions names were not always updated in order to ease patch review. In some cases, this leads to inconsistencies (e.g. enqueueInReadableStream takes a controller argument whereas its name suggests it works on a stream). Aligning with spec names would make code more coherent and ease comparison between implementation and spec.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161005/77033130/attachment.html>

More information about the webkit-unassigned mailing list