[Webkit-unassigned] [Bug 164061] [GTK] Initial implementation of JavaScriptCore glib bindings
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Nov 10 15:37:31 PST 2016
https://bugs.webkit.org/show_bug.cgi?id=164061
--- Comment #9 from Estêvão Samuel Procópio Amaral <tevaum at gmail.com> ---
Some considerations:
* Copied Source/WebKit2/UIProcess/API/gtk/WebKitPrivate.h to Source/JavaScriptCore/API/glib/JSCPrivate.h and added WEBKIT_DEFINE_SIMPLE_TYPE which defines a type without private structure (couldn't find a better name. Maybe when movind this stuff to WTF we sould use WEBKIT_DEFINE_TYPE and WEBKIT_DEFIINE_TYPE_WITH_PRIVATE?
* JSCValue stores a weak reference of the context it belongs to.
* Values are now cached in a HashMap inside JSCContext object and freed on context destruction.
* GRefPtrs and JSRetainPtrs were used to automatically ref/unref objects.
* Some object lifecycle tests were implemented to check if objects were really deallocated.
Hope this time I get less comments :P
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161110/7045bb33/attachment.html>
More information about the webkit-unassigned
mailing list