[Webkit-unassigned] [Bug 164437] Support TouchBar in WebKit

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 7 10:42:38 PST 2016


--- Comment #26 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 294046
  --> https://bugs.webkit.org/attachment.cgi?id=294046

View in context: https://bugs.webkit.org/attachment.cgi?id=294046&action=review

> Source/WebKit/mac/WebView/WebView.mm:9577
> +- (void)webViewAdditionsWillDestroyView

Could we rename this to -webViewWillDestroyView? (It looks like the "Additions" terminology is being dropped from other places).
Alternately, maybe we don't need a separate function on the WebView for performing cleanup in -[WebView dealloc] -- I think it makes sense just to move the cleanup logic directly to -dealloc and remove the -webViewWillDestroyView helper.

This also applies to the WebKit2 case (webViewImplAdditionsWillDestroyView)

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161107/9c413d05/attachment.html>

More information about the webkit-unassigned mailing list