[Webkit-unassigned] [Bug 164395] New: Web process crashed when receiving sighup signal

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 3 19:15:59 PDT 2016


            Bug ID: 164395
           Summary: Web process crashed when receiving sighup signal
    Classification: Unclassified
           Product: WebKit
           Version: Other
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: Critical
          Priority: P2
         Component: WebKit Gtk
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: bouanto at zoho.com
                CC: bugs-noreply at webkitgtk.org

I found that WebKit2 (not sure if it is WebKit2Gtk but I use it) crashes when receiving a sighup signal.
This even affects Epiphany where the application completely crashes, hence the Critical severity.

I don't know a simple way to reproduce the bug, so I post the way I can always reproduce the issue:

1. Configure the newsbeuter RSS client to use epiphany (put `browser "epiphany %u &"` in `~/.config/newsbeuter/config) and at a least a feed URL in `~/.config/newsbeuter/urls`.
2. Run the command `urxvt -e newsbeuter` from the terminal.
3. Open a feed (with Enter), then a link (with O — capital o): this will open epiphany.
4. Exit newsbeuter (by hitting twice q): this will make epiphany crash.

Note that I do not get this issue if I run the command `newsbeuter` instead of `urxvt -e newsbeuter`.
This issue does not happen in other web browsers.

While debugging the web process with gdb, I see the following:

[Thread 0x7fde77556700 (LWP 9825) exited]

Thread 1 "WebKitWebProces" received signal SIGHUP, Hangup.
0x00007fdedc34c48d in poll () from /usr/lib/libc.so.6
(gdb) cont
Couldn't get registers: Aucun processus de ce type.
Couldn't get registers: Aucun processus de ce type.
Couldn't get registers: Aucun processus de ce type.
(gdb) [Thread 0x7fde5d12e700 (LWP 9842) exited]
[Thread 0x7fde5fdf2700 (LWP 9829) exited]
[Thread 0x7fde74dff700 (LWP 9828) exited]
[Thread 0x7fde76d55700 (LWP 9827) exited]
[Thread 0x7fdec4b11700 (LWP 9824) exited]
[Thread 0x7fdec5312700 (LWP 9823) exited]
[Thread 0x7fdec6314700 (LWP 9818) exited]
[Thread 0x7fdec6b15700 (LWP 9817) exited]
[Thread 0x7fdec8bfc700 (LWP 9816) exited]
[Thread 0x7fdedf0159c0 (LWP 9805) exited]

At first, I thought it has something to do with gdbus (because I sometimes saw the message "Thread gdbus exited" or something similar), but the MiniBrowser also has this issue and I don't think it uses gdbus.

If you are unable to reproduce this issue or want more information, feel free to ask.

I run ArchLinux with
epiphany 3.22.1
webkit2gtk 2.14.2

Thanks to fix this issue.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161104/cb96d58d/attachment-0001.html>

More information about the webkit-unassigned mailing list