[Webkit-unassigned] [Bug 164313] New: Remove RenderMathMLOperator::shouldAllowStretching

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 2 02:24:15 PDT 2016


            Bug ID: 164313
           Summary: Remove RenderMathMLOperator::shouldAllowStretching
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: MathML
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: fred.wang at free.fr
                CC: bfulgham at webkit.org

This is a legacy function from the old MathML code. Now that we support large operator in displaystyle, the name is confusing since it is not just vertical/horizontal "stretchy" operators any more. I believe that now we can just expand it inside RenderMathMLOperator::updateMathOperator() by doing something like:

if (isStretchy())
    type = isVertical() ? MathOperator::Type::VerticalOperator : MathOperator::Type::HorizontalOperator;
else if (textContent() && isLargeOperatorInDisplayStyle())
    type = MathOperator::Type::DisplayOperator;
    type = MathOperator::Type::NormalOperator;

and then the condition in RenderMathMLOperator::useMathOperator() will just become

m_mathOperator.type() != MathOperator::Type::NormalOperator || textContent() == minusSign

where we add the accessor MathOperator::type() { return m_operatorType; }

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161102/60997a94/attachment.html>

More information about the webkit-unassigned mailing list