[Webkit-unassigned] [Bug 157693] Extend protector naming code style guideline to cover operator= assignment

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 13 16:43:33 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=157693

--- Comment #1 from Brady Eidson <beidson at apple.com> ---
(In reply to comment #0)
> 
> But we need to cover operator= assignment, as well.
> RefPtr<Node> protector = node;
> RefPtr<Node> protectedThis = this;

There's two ways to cover these cases:
1 - Extend the rule to enforce proper naming in these cases
2 - Extend the rule to disallow these cases and to prefer protector(node)-style initialization, instead.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160513/8c704020/attachment.html>


More information about the webkit-unassigned mailing list