[Webkit-unassigned] [Bug 153361] AX: new lines in content editable elements don't notify accessibility

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 31 22:56:43 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=153361

Ryosuke Niwa <rniwa at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #275266|review?                     |review+
              Flags|                            |

--- Comment #51 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 275266
  --> https://bugs.webkit.org/attachment.cgi?id=275266
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=275266&action=review

r=me with comments.

> Source/WebCore/editing/CompositeEditCommand.cpp:88
> +void AccessibilityUndoReplacedText::confgureTextToBeDeletedByUnapplyIndexesWithEditCommandEndingSelection(const VisibleSelection& selection)

This is an overly long function name.  We don't normally use "configure" prefix these things.
I think something along the line of setTextDeletedByUnapplyRangeFromEndingSelection will suffice.

> Source/WebCore/editing/CompositeEditCommand.cpp:98
> +void AccessibilityUndoReplacedText::confgureTextToBeDeletedByUnapplyStartIndexWithEditCommandStartingSelection(const VisibleSelection& selection)

Ditto about the function name.

> Source/WebCore/editing/CompositeEditCommand.cpp:752
> +static EditAction deleteSelectionEditingActionForEditingAction(EditAction editingAction)

This function name doesn't tell us what kind of conversion we're doing.
This might be a rare case in which inlining the code below as in:
editingAction() == EditActionCut ? EditActionCut : EditActionDelete
might be more clear.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160401/12488113/attachment.html>


More information about the webkit-unassigned mailing list