[Webkit-unassigned] [Bug 155574] [iOS] Allow clients to hide the accessory view on a form input session

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 16 22:18:28 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=155574

mitz at webkit.org <mitz at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #274253|review?                     |review+
              Flags|                            |

--- Comment #2 from mitz at webkit.org <mitz at webkit.org> ---
Comment on attachment 274253
  --> https://bugs.webkit.org/attachment.cgi?id=274253
patch v1

View in context: https://bugs.webkit.org/attachment.cgi?id=274253&action=review

r=me

I am not setting cq+, in case you are inspired to change the name before committing this, but I’m fine with going with this name, and possibly changing it later.

> Source/WebKit2/UIProcess/API/Cocoa/_WKFormInputSession.h:45
> + at property (nonatomic) BOOL hidesAccessoryView WK_AVAILABLE(NA, WK_IOS_TBA);

This can be named better, but I don’t have a great suggestion. The things that I don’t like about this name are (a) an input session isn’t really a thing that hides (or shows) the accessory view (b) it’s strange to treat the accessory view as something that’s there by default and the input session can hide, but I understand how it would be misleading to name this property showsAccessoryView, because the accessory view isn’t shown for all input types.

Here’s a not-so-great suggestion:
    // Defaults to YES.
    @property BOOL accessoryViewMayShow;

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160317/31f49418/attachment-0001.html>


More information about the webkit-unassigned mailing list