[Webkit-unassigned] [Bug 149056] [GTK] Spellchecker rejects word when adding a period or colon character if there is no trailing space before the next word

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 3 08:55:41 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=149056

--- Comment #23 from Darin Adler <darin at apple.com> ---
Comment on attachment 272757
  --> https://bugs.webkit.org/attachment.cgi?id=272757
Expand newAdjacentwords selection from its boundaries

View in context: https://bugs.webkit.org/attachment.cgi?id=272757&action=review

>> Source/WebCore/editing/VisibleSelection.h:88
>> +    int getLength() const { return end().computeOffsetInContainerNode() - start().computeOffsetInContainerNode(); }
> 
> This naming is not consistent with WebKit coding style. We don’t use get in the name of functions like this.
> 
> This code is wrong. It will give an incorrect value any time the start and end positions are not in the same container node, or when they are in the same container node, but it is not a text node.

One way to make cases that cover that would be spelling check in words when the text of the word crosses multiple elements, such as <span> elements.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160303/fd538bc2/attachment.html>


More information about the webkit-unassigned mailing list