[Webkit-unassigned] [Bug 160109] [iOS] Clients should be able to decide if they want secure text entry in a form field

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 22 17:39:51 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=160109

--- Comment #2 from mitz at webkit.org <mitz at webkit.org> ---
Comment on attachment 284389
  --> https://bugs.webkit.org/attachment.cgi?id=284389
Patch for [iOS] Clients should be able to decide if they want secure text entry in a form field

View in context: https://bugs.webkit.org/attachment.cgi?id=284389&action=review

> Source/WebKit2/UIProcess/API/Cocoa/_WKFormInputSession.h:47
> + at property (nonatomic) BOOL shouldUseSecureTextEntry WK_API_AVAILABLE(ios(WK_IOS_TBA));

The name implies that setting the property to NO means that secure text entry won’t be used, but that’s not the case. The property only works in one direction, forcing secure text entry to be used where otherwise it wouldn’t. Maybe a name like “forceSecureTextEntry” would express this better?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160723/4eaa4c5b/attachment-0001.html>


More information about the webkit-unassigned mailing list