[Webkit-unassigned] [Bug 159679] New: Split the pixel data of ImageFrame to a separate class
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jul 12 10:21:23 PDT 2016
https://bugs.webkit.org/show_bug.cgi?id=159679
Bug ID: 159679
Summary: Split the pixel data of ImageFrame to a separate class
Classification: Unclassified
Product: WebKit
Version: WebKit Nightly Build
Hardware: Unspecified
OS: Unspecified
Status: NEW
Severity: Normal
Priority: P2
Component: Images
Assignee: webkit-unassigned at lists.webkit.org
Reporter: sabouhallawa at apple.com
The goal is to have one class for the ImageFrame. Currently we have two very similar implementations: one is defined for non CG ports "ImageFrame", which is defined in /platform/image-decoders/ImageDecoder.h, and the second is "FrameData", which is defined in platform/graphics/BitmapImage.h.
We begin by moving the pixel data manipulation part in ImageFrame into a separate class and then make it optional (allocated on demand). So for the CG case, BitmapPixels object will not be allocated because all the decoding is done by CG.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160712/4b9684de/attachment.html>
More information about the webkit-unassigned
mailing list