[Webkit-unassigned] [Bug 159259] Duplicated code in DrawingAreaImpl and CoordinatedDrawingArea

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 6 02:00:51 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=159259

Zan Dobersek <zan at falconsigh.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #282750|review?                     |review+
              Flags|                            |

--- Comment #5 from Zan Dobersek <zan at falconsigh.net> ---
Comment on attachment 282750
  --> https://bugs.webkit.org/attachment.cgi?id=282750
Updated patch

View in context: https://bugs.webkit.org/attachment.cgi?id=282750&action=review

> Source/WebKit2/WebProcess/WebPage/AcceleratedDrawingArea.cpp:91
> +void AcceleratedDrawingArea::scroll(const IntRect& scrollRect, const IntSize& scrollDelta)
> +{
> +    if (!m_isPaintingEnabled)
> +        return;
> +
> +    m_layerTreeHost->scrollNonCompositedContents(scrollRect);
> +}
> +
> +void AcceleratedDrawingArea::pageBackgroundTransparencyChanged()
> +{
> +    if (m_layerTreeHost)
> +        m_layerTreeHost->pageBackgroundTransparencyChanged();
> +}

These differences in null-checking m_layerTreeHost are annoying.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160706/5bcc3ad3/attachment.html>


More information about the webkit-unassigned mailing list