[Webkit-unassigned] [Bug 153330] Fix bugs caused by incorrect usage of "branch" vs. "branchName".

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 27 13:50:25 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=153330

Daniel Bates <dbates at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #269586|review?                     |review+
              Flags|                            |

--- Comment #4 from Daniel Bates <dbates at webkit.org> ---
Comment on attachment 269586
  --> https://bugs.webkit.org/attachment.cgi?id=269586
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=269586&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/BuildbotQueueView.js:113
> +    _popoverLinesForCommitRange: function(trac, branch, firstRevisionNumber, lastRevisionNumber)

I'm assuming you plan to make more use of the branch object in a subsequent patch than to get the branch name. Currently this function only makes use of the branch name.

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/tests/tests.js:115
> +    var branch = this.trunkBranch;

This variable is used exactly once and I do not feel that its name makes the purpose of this variable any more understandable than its values. I suggest that we inline the value of this variable into the line below (line 116) and remove this variable.

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/tests/tests.js:129
> +    var branch = this.trunkBranch;

By a similar argument as above, I suggest inlining the value of this variable where its referenced and remove this variable.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160127/595d276d/attachment.html>


More information about the webkit-unassigned mailing list