[Webkit-unassigned] [Bug 153116] Need ability to specify alternate image for AutoFill button in input fields

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 20 15:19:53 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=153116

--- Comment #15 from Zach Li <zacharyli323 at gmail.com> ---
Comment on attachment 269302
  --> https://bugs.webkit.org/attachment.cgi?id=269302
Patch v2

View in context: https://bugs.webkit.org/attachment.cgi?id=269302&action=review

>> Source/WebCore/html/TextFieldInputType.cpp:621
>> +        return;
> 
> Please remove this code as it is unnecessary to runtime assert the button type because our use of the switch statement below and AutoFillButtonType being a enum class implies that a compile-time failure will occur if a enumerator value is added to-/renamed/removed from- AutoFillButtonType and the switch (below) is not updated.

Okay.

>> Source/WebKit2/WebProcess/InjectedBundle/API/c/WKBundleNodeHandle.cpp:49
>> +    return WebCore::AutoFillButtonType::Credentials;
> 
> Are these lines necessary? I thought the supported versions of clang/gcc were smart enough to realize that a switch block for an enum/enum class handles all possible code paths and hence the proposed added code is unreachable.

These lines are necessary. When I tried to remove them, I got "control may reach end of non-void function."

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160120/dc478703/attachment.html>


More information about the webkit-unassigned mailing list