[Webkit-unassigned] [Bug 153230] Network cache: old pages returned by disk cache on history navigation after session is restored

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 4 09:24:00 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=153230

--- Comment #12 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 270655
  --> https://bugs.webkit.org/attachment.cgi?id=270655
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=270655&action=review

What I would suggest would be:
1. Revert http://trac.webkit.org/changeset/181815 so that our API has a "allowStaleContent" parameter again (which I find clearer that the approach in this patch)
2. Add a setting to decide in restoreSession() if we want to allow stale content or not.
3. Set this setting to True on iOS and False elsewhere.

> Source/WebCore/history/HistoryItem.h:206
> +    void setShouldRevalidateInDiskCacheOnly(bool revalidateInDiskCache) { m_shouldRevalidateInDiskCacheOnly = revalidateInDiskCache; }

I think the naming here is not very clear. Also, I am not sure why we need to add a data member to HistoryItem.

> Source/WebKit2/WebProcess/WebCoreSupport/SessionStateConversion.h:41
> +    APIRequest

I personally don't find this to be clear.

> Source/WebKit2/WebProcess/WebPage/WebPage.cpp:2187
> +    restoreSessionInternal(itemStates, SessionRestoreMode::APIRequest);

I think allowing stale content on session restore should be based on a setting. I know that we want to keep allowing stale content on iOS for example.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160204/b2c494b9/attachment.html>


More information about the webkit-unassigned mailing list