[Webkit-unassigned] [Bug 161053] New: Rename MathMLInlineContainerElement to MathMLPresentationElement

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 22 12:40:40 PDT 2016


            Bug ID: 161053
           Summary: Rename MathMLInlineContainerElement to
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: All
                OS: All
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: MathML
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: fred.wang at free.fr
            Blocks: 160543

Another step for bug 160543.

MathMLInlineContainerElement sounds a bad name for something that is now going to produce RenderMathMLBlocks. At the moment most of the presentation MathML elements are actually MathMLInlineContainerElement and I believe most of the code of MathMLElement could be moved in that derived class. A MathMLUnknownElement class could be introduced for unknown elements, following what is done in SVG or HTML classes.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160822/41389b61/attachment.html>

More information about the webkit-unassigned mailing list