[Webkit-unassigned] [Bug 160771] [GTK] HTML special symbol © doubled in render output after refresh

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 11 12:04:32 PDT 2016


Carlos Alberto Lopez Perez <clopez at igalia.com> changed:

           What    |Removed                     |Added
                 CC|                            |clopez at igalia.com

--- Comment #2 from Carlos Alberto Lopez Perez <clopez at igalia.com> ---
I tried loading your testcase on a standard apache webserver but I got this error:

PHP Parse error:  syntax error, unexpected 'version' (T_STRING) in xhtmlent.php on line 3, referer: https://people.igalia.com/clopez/wkbug/160771/

I fixed it like this:

$ cat xhtmlent.php 
header('Content-Type: application/xhtml+xml; charset=ISO-8859-1');
echo '<?xml version="1.0" ?>';
echo '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">';
echo '<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de" dir="ltr"><head><title>test</title></head><body>&copy;</body></html>';

And uploaded it to here: https://people.igalia.com/clopez/wkbug/160771/xhtmlent.php

I tried refreshing several times with epiphany (2.12) and the minibrowser (trunk) and I'm not able to reproduce the issue. I only see a (c) symbol.

Are you able to reproduce it on the page I uploaded ?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160811/139f4c63/attachment.html>

More information about the webkit-unassigned mailing list