[Webkit-unassigned] [Bug 160543] New: [meta] Reorganize the MathMLElement hierarchy

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 4 03:50:43 PDT 2016


            Bug ID: 160543
           Summary: [meta] Reorganize the MathMLElement hierarchy
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: All
                OS: All
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: MathML
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: fred.wang at free.fr
                CC: alex at igalia.com, rego at igalia.com
        Depends on: 160540, 160542

I've opened bug 160540 and bug 160542 as two simple improvements.

MathMLInlineContainerElement also sounds a bad name for something that is now going to produce RenderMathMLBlocks. The update in MathMLInlineContainerElement::childrenChanged is also probably only necessary in mrow-like elements (mrow of element with inferred mrow like msqrt) but MathMLInlineContainerElement is used for other elements like fraction or scripts.

At the moment most of the elements are actually MathMLInlineContainerElement and I believe most of the code of MathMLElement could be moved in a derived class. Maybe the following hierarchy will be better:

MathMLElement < MathMLPresentationElement

MathMLPresentationElement < MathMLAnnotationElement, MathMLFractionElement, MathMLRowElement, MathMLScriptsElement, MathMLSelectElement, MathMLSpaceElement, MathMLTokenElement

MathMLRowElement < MathMLMencloseElement, MathMLPaddedElement, MathMLMathElement

MathMLScriptsElement < MathMLUnderOverElement

MathMLTokenElement < MathMLOperatorElement

We do like SVG and add a class MathMLUnknownElement deriving from MathMLElement that return false for rendererIsNeeded and that is used as a fallback class.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160804/0450df1d/attachment.html>

More information about the webkit-unassigned mailing list