[Webkit-unassigned] [Bug 155750] [GTK] Add kinetic scrolling

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 14 07:57:08 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=155750

--- Comment #7 from Adrien Plazas <aplazas at igalia.com> ---
Comment on attachment 276397
  --> https://bugs.webkit.org/attachment.cgi?id=276397
WIP patch

View in context: https://bugs.webkit.org/attachment.cgi?id=276397&action=review

> Source/WebCore/platform/ScrollAnimationKinetic.cpp:144
> +    m_scrollHistory.append(ScrollEvent(orientation, step * multiplier, currentTime));

What about letting ScrollAnimatorGtk handle the scrolling history and passing the computed inertia to ScrollAnimationKinetic when triggering inertial scrolling? This may help using the velocity values from the swipe gesture directly.

> Source/WebKit2/UIProcess/gtk/GestureController.cpp:218
> +void GestureController::SwipeGesture::swipe(SwipeGesture* swipeGesture, double x, double y, GtkGesture* gesture)

x and y (which should probably be named velocityX and velocityY) could (should?) be used to trigger inertial scrolling.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160414/22d6e09a/attachment.html>


More information about the webkit-unassigned mailing list