[Webkit-unassigned] [Bug 156462] [GTK] Rework scrollbars theming code for GTK+ 3.20

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 12 05:13:51 PDT 2016


--- Comment #3 from Carlos Garcia Campos <cgarcia at igalia.com> ---
Comment on attachment 276138
  --> https://bugs.webkit.org/attachment.cgi?id=276138

View in context: https://bugs.webkit.org/attachment.cgi?id=276138&action=review

>> Source/WebCore/platform/gtk/RenderThemeGadget.cpp:70
>> +    // Scrollbars need to use its GType to be able to get non-CSS style properties.
> Wow, I thought the type was ignored....

Me too, but otherwise gtk_style_context_get_style() fails when trying to get has-*-steppers properties.

>> Source/WebCore/platform/gtk/ScrollbarThemeGtk.cpp:309
>> +    // painting the thumb can be skipped. We don't have to be exact here.
> I would name the method something like ScrollbarThemeGtk::probablyHasThumb.

This is inherited, it's pure virtual of ScrollbarThemeComposite

>> Source/WebCore/platform/gtk/ScrollbarThemeGtk.h:65
>> +    bool m_hasForwardButtonStartPart : 1;
> I don't pretend to know if using a bitfield here would improve performance because due to better cache locality, or hurt performance due to the nature of bitfields (seems more likely to me?), but it only saves three bytes, and it's not like this structure is going to be allocated frequently (should be just once, right?) so I would personally use normal bools here.

This is a singleton. We didn't use bool nor bitfield before because we used the member addresses directly in gtk_style_context_get_style(), but now that with newer GTK+ we have a different approach and we have to set the values individually, I thought it wouldn't hurt to use bool : 1 for these values, but I agree this doesn't make a huge difference.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160412/010359da/attachment-0001.html>

More information about the webkit-unassigned mailing list