[Webkit-unassigned] [Bug 149542] New: Rename some JIT functions to more meaningful names.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 24 14:54:54 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=149542

            Bug ID: 149542
           Summary: Rename some JIT functions to more meaningful names.
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Local Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

We will rename the following:
    isOperandConstantImmediateDouble => isOperandConstantDouble
    getOperandConstantImmediateInt => getOperandConstantInt
    getConstantOperandImmediateInt => getOperandConstantInt

    emitJumpIfImmediateInteger => emitJumpIfInt
    emitJumpIfNotImmediateInteger => emitJumpIfNotInt
    emitJumpIfNotImmediateIntegers => emitJumpIfNotInt
    emitPatchableJumpIfNotImmediateInteger => emitPatchableJumpIfNotInt
    emitJumpSlowCaseIfNotImmediateInteger => emitJumpSlowCaseIfNotInt
    emitJumpSlowCaseIfNotImmediateNumber => emitJumpSlowCaseIfNotNumber
    emitJumpSlowCaseIfNotImmediateIntegers => emitJumpSlowCaseIfNotInt
    emitFastArithReTagImmediate => emitTagInt
    emitTagAsBoolImmediate => emitTagBool

    isOperandConstantImmediateInt => isOperandConstantInt
    isOperandConstantImmediateChar => isOperandConstantChar

    emitJumpIfImmediateNumber => emitJumpIfNumber
    emitJumpIfNotImmediateNumber => emitJumpIfNotNumber
    emitFastArithImmToInt - Deleted because this is an empty function.
    emitFastArithIntToImmNoCheck => emitTagInt
    emitPutImmediateToCallFrameHeader => emitPutToCallFrameHeader

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150924/61ac480c/attachment.html>


More information about the webkit-unassigned mailing list