[Webkit-unassigned] [Bug 150124] New: [Win] Enforce launcher/library naming scheme

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 14 10:08:16 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=150124

            Bug ID: 150124
           Summary: [Win] Enforce launcher/library naming scheme
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKit Misc.
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: bfulgham at webkit.org

There are several compilation units on Windows that have the same target name, differing only in file extension:

MiniBrowser.exe and MiniBrowser.dll
DumpRenderTree.exe and DumpRenderTree.dll

This causes trouble with the debugging symbols, because both "MiniBrowser.exe" and "MiniBrowser.dll" want to produce "MiniBrowser.pdb" for their symbols. This creates a race condition during builds that results in one of the two sets of debugging symbols being lost, which causes problems with producing usable stack traces.

To correct these, we will change the DLL build rules to generate "{Name}Lib.DLL", so that the build output will be:

MiniBrowser.exe -> MiniBrowser.pdb
MiniBrowserLib.dll -> MiniBrowserLib.pdb
DumpRenderTree.exe -> DumpRenderTree.pdb
DumpRenderTreeLib.exe -> DumpRenderTreeLib.pdb

This should resolve these symbol loading issues and help us get usable stack traces.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151014/5e479b7a/attachment.html>


More information about the webkit-unassigned mailing list