[Webkit-unassigned] [Bug 148967] AX: ARIA 1.1 implement aria-colcount, aria-colindex, aria-colspan, aria-rowcount, aria-rowindex and aria-rowspan

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 9 14:37:50 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=148967

--- Comment #5 from Nan Wang <n_wang at apple.com> ---
Comment on attachment 262789
  --> https://bugs.webkit.org/attachment.cgi?id=262789
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=262789&action=review

For iOS I'm thinking of adding new methods to expose those values. I might open a new bug for iOS and tests. But seems iOS is not speaking table row/column count or indexes now.

>> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:96
>> +    unsigned rowSpan = ariaRowSpan();
> 
> how do we distinguish 0 from no value?

If no value, the function will return 1 as default.

>> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:101
>> +        rowSpan = 1;
> 
> can you put this blob into a separate method

Ok

>> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:145
>> +}
> 
> i know that column/rowIndex are used by VO to get data out of the table sometimes. will this mess things up?

This is only for non-native tables, so I think the colspan/rowspan attributes won't be affected from this code. If author didn't set aria-colspan/aria-rowspan, the range.second will be 1 as before.

>> Source/WebCore/accessibility/AccessibilityTable.cpp:695
>> +    int rowCountInt = rowCountValue.toInt();
> 
> if there's no aria_rowCount set, won't toInt() == 0? which seems like the wrong default value right

My idea is to return the value only if the aria-rowcount is greater than the rendered table row count. Otherwise just return -1, and VO doesn't have to worry about speaking it.
The spec says: authors must set the value of aria-rowcount to -1 to indicate that the value should not be calculated by the user agent. Not sure if we should do something special about it.

>> Source/WebCore/accessibility/AccessibilityTableRow.cpp:152
>> +    for (unsigned i = 0; i < rowChildren.size(); i++) {
> 
> are we able to use the better iterators for accessibility children
> 
> for (const auto& cell in rowChildren)

Ok

--- Comment #6 from Nan Wang <n_wang at apple.com> ---
Comment on attachment 262789
  --> https://bugs.webkit.org/attachment.cgi?id=262789
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=262789&action=review

For iOS I'm thinking of adding new methods to expose those values. I might open a new bug for iOS and tests. But seems iOS is not speaking table row/column count or indexes now.

>> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:96
>> +    unsigned rowSpan = ariaRowSpan();
> 
> how do we distinguish 0 from no value?

If no value, the function will return 1 as default.

>> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:101
>> +        rowSpan = 1;
> 
> can you put this blob into a separate method

Ok

>> Source/WebCore/accessibility/AccessibilityARIAGridCell.cpp:145
>> +}
> 
> i know that column/rowIndex are used by VO to get data out of the table sometimes. will this mess things up?

This is only for non-native tables, so I think the colspan/rowspan attributes won't be affected from this code. If author didn't set aria-colspan/aria-rowspan, the range.second will be 1 as before.

>> Source/WebCore/accessibility/AccessibilityTable.cpp:695
>> +    int rowCountInt = rowCountValue.toInt();
> 
> if there's no aria_rowCount set, won't toInt() == 0? which seems like the wrong default value right

My idea is to return the value only if the aria-rowcount is greater than the rendered table row count. Otherwise just return -1, and VO doesn't have to worry about speaking it.
The spec says: authors must set the value of aria-rowcount to -1 to indicate that the value should not be calculated by the user agent. Not sure if we should do something special about it.

>> Source/WebCore/accessibility/AccessibilityTableRow.cpp:152
>> +    for (unsigned i = 0; i < rowChildren.size(); i++) {
> 
> are we able to use the better iterators for accessibility children
> 
> for (const auto& cell in rowChildren)

Ok

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151009/6d4dd589/attachment.html>


More information about the webkit-unassigned mailing list