[Webkit-unassigned] [Bug 151494] [JSC] support Computed Property Names in destructuring Patterns

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 20 09:50:01 PST 2015


--- Comment #6 from Caitlin Potter (:caitp) <caitp at igalia.com> ---
> So this kind of expression is only allowed using the new feature you added recently that assigns to the rhs of the colon?

It was already possible to assign to the rhs of the colon, the consumeOrFail and other code duplication is here to keep it a bit more straight forward (instead of conditionally deciding how to behave depending on whether propertyExpression is null or not, further down). I don't have a strong opinion on it if people don't like the code duplication in the name of straightforwardness.


Adding some other tests

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151120/4a340015/attachment.html>

More information about the webkit-unassigned mailing list