[Webkit-unassigned] [Bug 150740] Link preview doesn't work on XHTML pages with Content-Type header as `application/xhtml+xml`

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 4 12:03:22 PST 2015


https://bugs.webkit.org/show_bug.cgi?id=150740

--- Comment #19 from Beth Dakin <bdakin at apple.com> ---
(In reply to comment #18)
> Another thought:
> 
> I don’t really know in what practical case I would not be over any element.
> Maybe it’s true past the bottom of the document? I think we’d almost always
> be over the body element if nothing else.
> 
> Given that, I’m not sure it’s valuable for us to prevent the gesture when
> not over an element. And I’m not sure it’s valuable for us to prevent clicks
> when not over an element.
> 
> To word it another way: How did we test the “not over an element” case?
> 
> If I’m right, we can probably just remove this entirely.

Very interesting thoughts. So, it turns out that it is very possible to not be over an element. I think that in normal hit testing, you will always be over an element (I think). But! The hit-testing code path that this code uses is unique to iOS and does all kinds of filtering to look for something clickable/tappable -- see Frame::nodeRespondingToClickEvents(). Now, I don't understand the historical reasons for that instead of normal hit testing, and I don't know if those reasons are still valid. But changing that seems like a big enough change that it should be done separately and with more thought.

So for now, I think I will change clickableElementName to isClickableElement just for clarity.

It seems like a small enough change that I can just make it and check it, but I would be happy to post a new patch if you prefer.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151104/1c4d23a2/attachment.html>


More information about the webkit-unassigned mailing list