[Webkit-unassigned] [Bug 145283] AX: debugging attributes for text markers

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 21 17:48:19 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=145283

chris fleizach <cfleizach at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #253542|                            |review-
              Flags|                            |

--- Comment #3 from chris fleizach <cfleizach at apple.com> ---
Comment on attachment 253542
  --> https://bugs.webkit.org/attachment.cgi?id=253542
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=253542&action=review

thanks

> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3796
> +    if ([attribute isEqualToString:@"AXTextMarkerDebugDescription"]) {

can you put these into a separate method completely and can you put the logic in an ObjC method so that these can be called from within the debugger itself

> Source/WebCore/accessibility/mac/WebAccessibilityObjectWrapperMac.mm:3797
> +        VisiblePosition visiblePosition = [self visiblePositionForTextMarker:(textMarker)];

i don't think the parens are necessary here
(textMarker)

> Source/WebCore/dom/Text.cpp:231
> +        result.appendLiteral("count=");

this looks like it should be length instead of count

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150522/5e34c4b5/attachment.html>


More information about the webkit-unassigned mailing list