[Webkit-unassigned] [Bug 144769] Pass String as reference in more places

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 7 23:44:05 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=144769

Daniel Bates <dbates at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #252654|review?                     |review+
              Flags|                            |

--- Comment #3 from Daniel Bates <dbates at webkit.org> ---
Comment on attachment 252654
  --> https://bugs.webkit.org/attachment.cgi?id=252654
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=252654&action=review

> Source/JavaScriptCore/parser/Parser.h:656
> +    void setErrorMessage(const String& msg)

For your consideration, I suggest we rename msg to message.

> Source/JavaScriptCore/parser/Parser.h:670
> +    NEVER_INLINE void updateErrorWithNameAndMessage(const char* beforeMsg, const String& name, const char* afterMsg)

For your consideration, I suggest we rename beforeMsg and afterMsg to beforeMessage and afterMessage, respectively.

> Source/WebCore/bindings/js/SerializedScriptValue.cpp:684
> +    void dumpString(const String& str)

For your consideration, I suggest we rename parameter str to string.

> Source/WebCore/bindings/js/SerializedScriptValue.cpp:694
> +    void dumpStringObject(const String& str)

Ditto.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150508/cf0cbb72/attachment.html>


More information about the webkit-unassigned mailing list