[Webkit-unassigned] [Bug 143140] New: IteratorClose should be called when break statement jumps over the target for-of loop

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 27 12:07:40 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=143140

            Bug ID: 143140
           Summary: IteratorClose should be called when break statement
                    jumps over the target for-of loop
    Classification: Unclassified
           Product: WebKit
           Version: 528+ (Nightly build)
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: utatane.tea at gmail.com

When executing the following script,

var iter = ...;

outer: for (var i of array) {
    for (var j of iter) {
        break outer;
    }
}

iter.return should be called.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150327/0d46febc/attachment-0002.html>


More information about the webkit-unassigned mailing list