[Webkit-unassigned] [Bug 142995] [WTF] Use adoptUniquePtr and leakUniquePtr until C++14 unique_ptr capture in Lambda becomes available

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 23 19:16:44 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=142995

--- Comment #2 from Gyuyoung Kim <gyuyoung.kim at webkit.org> ---
Comment on attachment 249306
  --> https://bugs.webkit.org/attachment.cgi?id=249306
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=249306&action=review

I would like to delegate this patch's review to Darin.

> Source/WTF/ChangeLog:8
> +        make an adopt function and leak function for unique_ptr so that the pair is more readable.

Add a new line.

> Source/WTF/wtf/StdLibExtras.h:401
> +namespace WTF {

"namespace WTF" was already defined in 120 line. Looks like unnecessary namespace definition if this templates are moved into it.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150324/4d903e52/attachment-0002.html>


More information about the webkit-unassigned mailing list