[Webkit-unassigned] [Bug 142836] Add events related to force click gesture

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 20 14:40:01 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=142836

Beth Dakin <bdakin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |darin at apple.com

--- Comment #28 from Beth Dakin <bdakin at apple.com> ---
(In reply to comment #27)
> Comment on attachment 249124 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=249124&action=review
> 
> > Source/WebCore/dom/Element.cpp:2137
> > +#if ENABLE(MOUSE_FORCE_EVENTS)
> 
> Is there a reason we don't just disappear these functions if this isn't
> enabled?
> 

Not necessarily a good one! I was just trying to minimize the number of spots I put the #ifs since they make code harder to read, but I am open to anything really.

> > Source/WebCore/dom/WebKitMouseForceChangedEvent.cpp:32
> > +
> 
> Where's the #if ENABLE(MOUSE_FORCE_EVENTS)?
> 

That does seem like an oversight.

> > Source/WebCore/page/DOMWindow.idl:272
> > +    [NotEnumerable] attribute EventHandler onwebkitmouseforcecancelled;
> 
> should these have Conditional=MOUSE_FORCE_EVENT?

SO!!! I am glad you asked, because I am really confused about this. Earlier versions of my patch included this. However, in http://trac.webkit.org/changeset/181507 Darin removed all conditionals from DOMWindow.idl, and I am very confused about why. I asked Anders, who reviewed the patch, and he wasn't totally sure about it either. I should really ask Darin. Oh, I will cc him!

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150320/a4f70211/attachment-0002.html>


More information about the webkit-unassigned mailing list