[Webkit-unassigned] [Bug 146533] AX: Selection change as a result of focusing an element should include that information in the intent
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Jul 2 16:09:46 PDT 2015
https://bugs.webkit.org/show_bug.cgi?id=146533
chris fleizach <cfleizach at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |cfleizach at apple.com
--- Comment #8 from chris fleizach <cfleizach at apple.com> ---
(In reply to comment #5)
> (In reply to comment #4)
> > Comment on attachment 255970 [details]
> > patch
> >
> > View in context:
> > https://bugs.webkit.org/attachment.cgi?id=255970&action=review
> >
> > > Source/WebCore/accessibility/AccessibilityRenderObject.cpp:1686
> > > + if (AXObjectCache* cache = axObjectCache())
> >
> > i don't think you have to worry about axObjectCache() being nullptr inside
> > of an AX object
>
> ok
>
> >
> > > Source/WebCore/dom/Element.h:325
> > > + static AXTextStateChangeIntent defaultFocusTextStateChangeIntent() { return AXTextStateChangeIntent(AXTextStateChangeTypeSelectionMove, AXTextSelection { AXTextSelectionDirectionDiscontiguous, AXTextSelectionGranularityUnknown, true }); }
> >
> > is this one different from the default AXTextStateChangeIntent();
> > for cases, like
> > select(Element::defaultFocusTextStateChangeIntent());
> > it would be nice to not have to pass the argument
>
> Yes. The default AXTextStateChangeIntent() is all unknown types and
> focusChange is false. I could have the default value be
> Element::defaultFocusTextStateChangeIntent() but that feels dangerous.
>
> >
> > > Source/WebCore/editing/FrameSelection.cpp:174
> > > + AXTextStateChangeIntent newIntent;
> >
> > can we remove the else and just initialize with
> > newIntent = intent;
>
> ok
>
> >
> > > Source/WebCore/html/HTMLTextFormControlElement.h:113
> > > + void restoreCachedSelection(const AXTextStateChangeIntent& = AXTextStateChangeIntent());
> >
> > AXTextStateChangeIntent is looking a bit wordy. Since this is being used
> > all over non accessibility code, maybe the name should be changed to
> > something like
> >
> > TextIntention
>
> Would it be ok to do that in a future patch? I'd like to keep this one small.
probably ok
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150702/2160eca6/attachment.html>
More information about the webkit-unassigned
mailing list