[Webkit-unassigned] [Bug 141869] Change the "undefined is not a function" error into "foo.bar is not a function"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 23 14:21:30 PST 2015


https://bugs.webkit.org/show_bug.cgi?id=141869

--- Comment #3 from Saam Barati <saambarati1 at gmail.com> ---
(In reply to comment #2)
> Maybe Saam can take this one down.

Sure, but we already do something similar:

`
var x = {};
x.foo()
`
==>
"Exception: TypeError: undefined is not a function (evaluating 'x.foo()')"

Maybe we should just switch up the wording? I personally like it the way it is now, 
because it tells you both what the problem is and where the problem is 
(Chrome just says where it is, but not that it's undefined).
Maybe we should make the x.foo() part more prominent and not in parens, something like:

"Exception: TypeError: when evaluating 'x.foo()': undefined is not a function"

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150223/d6637de4/attachment-0002.html>


More information about the webkit-unassigned mailing list