[Webkit-unassigned] [Bug 141153] New: [GDB] Couldn't use gdb tool well for WebKit GTK

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 2 04:16:16 PST 2015


            Bug ID: 141153
           Summary: [GDB] Couldn't use gdb tool well for WebKit GTK
    Classification: Unclassified
           Product: WebKit
           Version: 528+ (Nightly build)
          Hardware: Unspecified
                OS: Linux
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKit Gtk
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: clover2123 at gmail.com

I built WebKit Gtk(revision 174059) on Ubuntu 14.04 with follow commands

$ Tools/Scripts/build-webkit --gtk --debug

and finally got MiniBrowser file in WebKitBuild/Debug/bin folder.

but when I debug MiniBrowser with gdb tool, I couldn't set breakpoints for it.

for example, I ran the following simple html file 

== test.html == 
window.onload = function() {
    var now = new Date();
    var a = 4;
    var c = Math.sqrt(4);

and set some breakpoints in WebCore and JavaScriptCore module 

but when I ran MiniBrowser in gdb, it finished execution(html load) without any break even if some breakpoints were set.

I ran MiniBrowser in gdb with follow commands

$ Tools/jhbuild/jhbuild-wrapper --gtk run gdb --args WebKitBuild/Debug/bin/MiniBrowser

$ b JSC::evaluate

$ b WebCore::Document::dispatchWindowLoadEvent

did i do something wrong? (maybe multi-thread issue?)

what should i do to debug WebCore/JavaScriptCore module in MiniBrowser?

I'm debugging MiniBrowser to know the loading sequence of html file in WebKit Gtk.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150202/5342e3c6/attachment-0002.html>

More information about the webkit-unassigned mailing list