[Webkit-unassigned] [Bug 152424] Cache redirects as separate entries

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 18 10:38:09 PST 2015


https://bugs.webkit.org/show_bug.cgi?id=152424

Alex Christensen <achristensen at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #267630|review?                     |review+
              Flags|                            |

--- Comment #3 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 267630
  --> https://bugs.webkit.org/attachment.cgi?id=267630
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=267630&action=review

r=me one these questions are addressed.

> Source/WebKit2/NetworkProcess/NetworkResourceLoader.cpp:185
> -    if (NetworkCache::singleton().isEnabled())
> +    if (canUseCache(request))

Did you change all uses of NetworkCache::singleton().isEnabled to canUseCache?  This seems like a very important change that we should've done long ago.

> Source/WebKit2/NetworkProcess/NetworkResourceLoader.cpp:-336
> -            // Make sure we don't keep a stale entry in the cache.

Why don't we need to remove any cache entries here any more?

> Source/WebKit2/NetworkProcess/NetworkResourceLoader.cpp:402
> +#if ENABLE(NETWORK_CACHE)

You might need an #else UNUSED_PARAM(request);
And maybe it should be called something like originalRequest.

> Source/WebKit2/NetworkProcess/NetworkResourceLoader.cpp:531
> +void NetworkResourceLoader::dispatchWillSendRequestForCacheEntry(std::unique_ptr<NetworkCache::Entry> entry)

This is only called from one place and might not need its own function unless you plan to use it from other places in the future.

> LayoutTests/http/tests/cache/disk-cache/disk-cache-redirect-expected.txt:10
> +response source: Disk cache

How is the first response from the Disk cache?

> LayoutTests/http/tests/cache/disk-cache/disk-cache-redirect.html:17
> +  { responseHeaders: {'Cache-control': 'max-age=0' } },
> +  { responseHeaders: {'Cache-control': 'max-age=100' } },

If I'm correct, the first cache entry expires immediately, and the second cache entry does not expire immediately, so we test making a request for a cache entry that has expired.  Why don't we make another request after the second one to test making a request for a cache entry that has not expired?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151218/a4551327/attachment.html>


More information about the webkit-unassigned mailing list