[Webkit-unassigned] [Bug 152244] Add separate module for selection/measuring/drawing of stretchy operators

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 14 07:01:53 PST 2015


https://bugs.webkit.org/show_bug.cgi?id=152244

--- Comment #1 from Frédéric Wang (:fredw) <fred.wang at free.fr> ---
Here is a first analysis of how to split the class after bug 152242. At the moment there are some overlap with the member variable (e.g. m_stretchyData) or function (e.g. stretchTo), which makes things unclear.

RenderMathMLOperator class:

struct StretchyCharacter
static const short leftRightPairsCount
static const StretchyCharacter stretchyCharacters
setOperatorFlagAndScheduleLayoutIfNeeded
setOperatorFlagFromAttribute
setOperatorFlagFromAttributeValue
setOperatorPropertiesFromOpDictEntry
setOperatorProperties
isChildAllowed
stretchTo?
resetStretchSize
firstLineBaseline
computePreferredLogicalWidths
computeLogicalHeight (we should probably move that to a new "layout" function, so that we can set the actual width too)
rebuildTokenContent
updateTokenContent
updateFromElement
updateOperatorProperties
shouldAllowStretching
hasOperatorFlag
isLargeOperatorInDisplayStyle
stretchSize
isVertical
updateStyle
trailingSpaceError (to be removed when we compute the actual width in "layout" correctly and rewrite RenderMathMLRoot)
paintChildren

StretchyOperator class:

paintGlyph
boundsForGlyph
heightForGlyph
advanceForGlyph
maxWidth (to be used in computePreferredLogicalWidths)
getGlyphAssemblyFallBack
getDisplayStyleLargeOperator
findStretchyData
fillWithVerticalExtensionGlyph
fillWithHorizontalExtensionGlyph
paint
paintVerticalGlyphAssembly
paintHorizontalGlyphAssembly
stretchTo?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151214/e3c5de64/attachment-0001.html>


More information about the webkit-unassigned mailing list