[Webkit-unassigned] [Bug 150515] Safari background tabs should be fully suspended where possible.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 11 03:16:42 PST 2015


https://bugs.webkit.org/show_bug.cgi?id=150515

Ryosuke Niwa <rniwa at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #267167|review?                     |review+
              Flags|                            |

--- Comment #22 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 267167
  --> https://bugs.webkit.org/attachment.cgi?id=267167
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=267167&action=review

> Source/WebKit2/ChangeLog:7
> +

You should mention that you're adding a runtime flag to enable this feature via user defaults.

> Source/WebCore/page/Page.cpp:1855
> +void Page::scheduleTabSuspension(bool shouldSuspend)

It's weird for a function that can synchronously resume a document
to be called scheduleTabSuspension but I can't think of a better name now.

> Source/WebCore/page/Page.cpp:1870
> +void Page::timerFired()

This should be renamed to tabSuspensionTimerFired.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20151211/2829021f/attachment-0001.html>


More information about the webkit-unassigned mailing list