[Webkit-unassigned] [Bug 142719] AX: richer text change notifications

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 23 19:31:29 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=142719

--- Comment #105 from Doug Russell <d_russell at apple.com> ---
(In reply to comment #104)
> > > Source/WebCore/editing/ReplaceInsertIntoTextNodeCommand.h:37
> > > +    static Ref<ReplaceInsertIntoTextNodeCommand> create(PassRefPtr<Text> node, unsigned offset, const String& text, const String& deletedText, EditAction editingAction)
> > 
> > New code should not use PassRefPtr. See
> > <https://www.webkit.org/coding/RefPtr.html>.
> > 
> > > Source/WebCore/editing/ReplaceInsertIntoTextNodeCommand.h:43
> > > +    ReplaceInsertIntoTextNodeCommand(PassRefPtr<Text>, unsigned, const String&, const String&, EditAction);
> > 
> > New code should not use PassRefPtr. See
> > <https://www.webkit.org/coding/RefPtr.html>.
> 
> Switching these methods to RefPtr results in style errors:
> ERROR: Source/WebCore/editing/ReplaceDeleteFromTextNodeCommand.cpp:33:  The
> parameter type should use PassRefPtr instead of RefPtr. 
> [readability/pass_ptr] [5]
> 
> What's the appropriate type here?

Nevermind, didn't have a &&

> Function arguments
>  If a function does not take ownership of an object, the argument should be a raw reference or raw pointer.
>  If a function does take ownership of an object, the argument should be a Ref&& or a RefPtr&&. This includes many setter functions.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150424/8c79cc1e/attachment-0001.html>


More information about the webkit-unassigned mailing list