[Webkit-unassigned] [Bug 143357] New: Enhanced ability to dump JSC Options

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 2 20:04:08 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=143357

            Bug ID: 143357
           Summary: Enhanced ability to dump JSC Options
    Classification: Unclassified
           Product: WebKit
           Version: 528+ (Nightly build)
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

Some enhancements to how the JSC options work:

1. Add a JSC_showOptions option which take values: 0 = None, 1 = Overridden only, 2 = All, 3 = Verbose.
   The default is 0 (None).  This dumps nothing.
   With the Overridden setting, at VM initialization time, we will dump all option values that have been changed from their default.
   With the All setting, at VM initialization time, we will dump all option values.
   With the Verbose setting, at VM initialization time, we will dump all option values along with their descriptions (if available).

2. We now store a copy of the default option values.
   We later use this for comparison to tell if an option has been overridden, and print the default value for reference.
   As a result, we no longer need the didOverride flag since we can compute whether the option is overridden at any time.

3. Added description strings to some options to be printed when JSC_showOptions=3 (Verbose).  This will come in handy later when we want to rename some of the options to more sane names that are easier to remember.  For example, we can change Options::dfgFunctionWhitelistFile() to Options::dfgWhiteList(), and Options::slowPathAllocsBetweenGCs() to Options::forcedGcRate().  With the availability of the description, we can afford to use shorter and less descriptive option names, but they will be easier to remember and use for day to day debugging work.

   In this patch, I did not change the names of any of the options yet.  I only added description strings for options that I know about, and where I think the option name isn't already descriptive enough.

4. Also deleted some unused code.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150403/283f4397/attachment.html>


More information about the webkit-unassigned mailing list