[Webkit-unassigned] [Bug 136615] [GTK] Use a nicer HTTP authentication dialog
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Sep 11 23:33:18 PDT 2014
https://bugs.webkit.org/show_bug.cgi?id=136615
Carlos Garcia Campos <cgarcia at igalia.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #237966|review?, commit-queue? |review+, commit-queue-
Flag| |
--- Comment #16 from Carlos Garcia Campos <cgarcia at igalia.com> 2014-09-11 23:33:19 PST ---
(From update of attachment 237966)
View in context: https://bugs.webkit.org/attachment.cgi?id=237966&action=review
Thanks, I would only change a couple of things before landing.
> Source/WebKit2/UIProcess/API/gtk/WebKitAuthenticationDialog.cpp:122
> + label = gtk_label_new(message.get());
> + gtk_misc_set_alignment(GTK_MISC(label), 0, 0.5);
> + gtk_label_set_line_wrap(GTK_LABEL(label), TRUE);
> + gtk_label_set_max_width_chars(GTK_LABEL(label), 40);
> + gtk_widget_show(label);
> + gtk_box_pack_start(GTK_BOX(authBox), label, FALSE, FALSE, 0);
This is pretty much the same block than the previous one. We could move it to a helper function. Something like the createLabel you are removing, but without the padding parameter.
> Source/WebKit2/UIProcess/API/gtk/WebKitAuthenticationDialog.cpp:132
> + gtk_style_context_add_class(gtk_widget_get_style_context(loginLabel), "dim-label");
Use GTK_STYLE_CLASS_DIM_LABEL instead of "dim-label"
> Source/WebKit2/UIProcess/API/gtk/WebKitAuthenticationDialog.cpp:143
> + gtk_style_context_add_class(gtk_widget_get_style_context(passwordLabel), "dim-label");
Ditto.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list