[Webkit-unassigned] [Bug 136611] Pass certificate info as part of ResourceResponse

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 8 14:26:11 PDT 2014


--- Comment #13 from Antti Koivisto <koivisto at iki.fi>  2014-09-08 14:26:13 PST ---
> Seems like this should be inlined in the header. I wouldn’t put it in the class definition, but I would put it at the bottom of the header. Hate to have function call overhead for a simple getter like this.

I think we should only manually inline things that are meaningful in terms of performance (this isn't) or reduce number of code lines (single line accessors). Everything else goes to cpp.

One practical reason is that routine inlining often results in unnecessary includes from the header.

The compiler should really be smart enough to inline what it wants whether it is in cpp or h (==build WebKit with LTO).

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list