[Webkit-unassigned] [Bug 136449] [GTK] UserMedia Permission Request API
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 2 08:33:44 PDT 2014
https://bugs.webkit.org/show_bug.cgi?id=136449
--- Comment #6 from Carlos Garcia Campos <cgarcia at igalia.com> 2014-09-02 08:33:44 PST ---
(In reply to comment #4)
> Thanks for the review! I'm going to upload a new patch.
>
> (In reply to comment #53)
> > > Source/WebKit2/UIProcess/API/gtk/WebKitUserMediaPermissionRequest.cpp:124
> > > +const gchar* webkit_user_media_permission_get_origin(WebKitUserMediaPermissionRequest* request)
> >
> > Is a string enough to represent a security origin?
> >
>
> I don't know. That's all I needed in the MiniBrowser but it's a weak argument :)
> Also I wonder if that property should be stored in the parent class instead. I can also remove this for now and we'd add it later.
Yes, please.
> > > Source/WebKit2/UIProcess/API/gtk/WebKitUserMediaPermissionRequest.cpp:189
> > > + if (audio->value())
> > > + mediaParameters |= WEBKIT_USER_MEDIA_PARAMETERS_AUDIO;
> > > + if (video->value())
> > > + mediaParameters |= WEBKIT_USER_MEDIA_PARAMETERS_VIDEO;
> >
> > So parameters is the media type?
> >
>
> yes
>
> > > Source/WebKit2/UIProcess/API/gtk/WebKitUserMediaPermissionRequest.h:55
> > > +} WebKitUserMediaParameters;
> >
> > I find it a bit confusing, using Parameters for the media type, or will this be expanded eventually with more "parameters"?
> >
>
> I don't think there will be new parameters... Another option would simply be 2 boolean properties, I don't really mind changing this code but it'd be nice to decide so I don't lose more time with GObject :)
I'm fine with the flags, what I find confusing is the name "parameters" to refer to the media type this request is about.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list