[Webkit-unassigned] [Bug 137775] [GTK] Minibrowser : Add window fullscreen support for Minibrowser

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 23 04:16:03 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=137775

--- Comment #8 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > (In reply to comment #4)
> > > > (In reply to comment #3)
> > > > > (In reply to comment #2)
> > > > > > Comment on attachment 239941 [details]
> > > > > > Patch
> > > > > > 
> > > > > > View in context:
> > > > > > https://bugs.webkit.org/attachment.cgi?id=239941&action=review
> > > > > > 
> > > > > > > Tools/MiniBrowser/gtk/BrowserWindow.c:575
> > > > > > > +    if (!window->fullScreenIsEnabled) {
> > > > > > > +        gtk_window_fullscreen(GTK_WINDOW(window));
> > > > > > > +        gtk_widget_hide(window->toolbar);
> > > > > > > +        window->fullScreenIsEnabled = TRUE;
> > > > > > > +    } else {
> > > > > > > +        gtk_window_unfullscreen(GTK_WINDOW(window));
> > > > > > > +        gtk_widget_show(window->toolbar);
> > > > > > > +        window->fullScreenIsEnabled = FALSE;
> > > > > > > +    }
> > > > > > 
> > > > > > We already have code to enter/leave fullscreen when requested by wk, maybe
> > > > > > we can reuse that code to make it work also when requested by the user,
> > > > > > because there are some inconsistencies. The other code shows a message
> > > > > > explaining the user how to leave fullscreen mode, and the keybindings are f
> > > > > > or ESC, not F11. Also the other code takes care of showing/hide the findbar.
> > > > > 
> > > > > I think the code to enter/leave fullscreen is for HTML element/webview
> > > > > fullscreen and not for the minibrowser window itself.
> > > > 
> > > > Right.
> > > > 
> > > > > We don't need message
> > > > > and title for window to be displayed on fullscreen in this case. Most of the
> > > > > browsers (Chrome, Firefox, IE) uses F11 key to toggle browser window
> > > > > fullscreen and f or ESC for HTML elements. Please correct me if I am wrong.
> > > > 
> > > > Yes, Epiphany also uses F11, but also shows a message. In any case, my point
> > > > is that the code that enters/leaves fullscreen could be common in both
> > > > cases. Move the common logic to a function, and call it from both places.
> > > 
> > > There is no common code in BrowserWindow.c file for webkitView and window
> > > fullscreen except findbar hide. Are you suggesting to implement it in
> > > WebKitWebViewBase.cpp file to handle the F11 keypress event similar to ESC
> > > and F key handle?
> > 
> > Oh, you are right, sorry, I thought we were also doing the
> > fullscreen/unfullscreen in MB when entering/leaving fs, but that's done by
> > the web view. So, yes, it's enough to move the searchbar visibility code to
> > their own functions and call those from both places. Something like
> > browserWindowHideSearchBarForFullscreen() and
> > browserWindowShowSearchBarAfterFullscreen(), for example
> 
> Do you mean to say hide 'toolbar' in place of searchbar? We dont need to
> hide 'searchbar' as this beahviour is not needed in case of window
> fullscreen and needed in case of webview fullscreen.(checked in firefox and
> chrome).

I don't know why we hide the searchbar when entering fs TBH, I proposed it for consistency.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141023/aaf5b5bd/attachment-0002.html>


More information about the webkit-unassigned mailing list