[Webkit-unassigned] [Bug 137903] Use synchronous messages for keyEvent on iOS

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 21 11:26:13 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=137903

--- Comment #3 from Enrica Casucci <enrica at apple.com> ---
Comment on attachment 240164
  --> https://bugs.webkit.org/attachment.cgi?id=240164
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=240164&action=review

>> Source/WebKit2/UIProcess/WebPageProxy.cpp:1582
>> +void WebPageProxy::handleKeyboardEvent(const NativeWebKeyboardEvent& event, bool useSynchronousMessage)
> 
> Can this be made into an entirely separate code path? This code is so complicated that mixing sync and async code paths seems very confusing.
> 
> Or at the very least, the argument should be named, not a cryptic "true/false".

I don't think the code is that complicated and I did not want any duplication. The function has a default value of false, so all the other call sites don't even need to know about this parameter.
The only place where this is used is in WKContentViewInteraction where it is passed [self useSynchronousKeyEvent], which is pretty clear.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141021/b6339a74/attachment-0002.html>


More information about the webkit-unassigned mailing list