[Webkit-unassigned] [Bug 137597] Support activation behavior of link element
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sat Oct 11 16:59:15 PDT 2014
https://bugs.webkit.org/show_bug.cgi?id=137597
Benjamin Poulain <benjamin at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #239683|review? |review+, commit-queue-
Flag| |
--- Comment #6 from Benjamin Poulain <benjamin at webkit.org> 2014-10-11 16:59:09 PST ---
(From update of attachment 239683)
View in context: https://bugs.webkit.org/attachment.cgi?id=239683&action=review
The page is good, the additional test looks good too.
I have a minor comment. I r+, cq-, which means the patch is good but it cannot be integrated as it is because of minor review comments.
If you upload a new updated patch, I'll cq+ that one. If I get the chance tonight I'll just update this version and land manually.
Great job on this bug.
> Source/WebCore/dom/MouseEvent.cpp:193
> +bool MouseEvent::triggerActivationBehavior(const Event* event)
Seeing this being used in practice, the name does not look right. The function name implies it triggers the Activation Behavior.
I think canTriggerActivationBehavior() would be better.
> Source/WebCore/dom/MouseEvent.h:102
> + bool static triggerActivationBehavior(const Event*);
Should be "static bool" instead of "bool static" for WebKit style.
> Source/WebCore/html/HTMLAnchorElement.h:-124
> -
No need to change this line.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list