[Webkit-unassigned] [Bug 130837] Webkit2 doesnt build on powerpc 32 bits

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 17 14:23:04 PST 2014


Sasa Ostrouska <casaxa at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |casaxa at gmail.com

--- Comment #3 from Sasa Ostrouska <casaxa at gmail.com> ---
Hi I don't know if this is in some way related to this bug, but I'm trying to compile this from 2.5.90 up to 2.6.3 ending always at make install phase with the same error.

sasa at slack141-314:/tmp/DLG/logs/webkitgtk-2.6.3-2$ cat makeinstall.txt 
[  0%] Built target WebKit2-forwarding-headers
[  1%] Built target WTF
[  1%] Built target LLIntOffsetsExtractor
[ 12%] Built target JavaScriptCore
[ 13%] Built target ANGLESupport
[ 76%] Built target WebCore
[ 77%] Built target WebCorePlatformGTK
[ 78%] Built target fake-generated-webkitdom-headers
[ 84%] Built target GObjectDOMBindings
[ 84%] Built target WebKit2-fake-api-headers
Linking CXX shared library ../../lib/libwebkit2gtk-4.0.so
CMakeFiles/WebKit2.dir/Platform/IPC/Connection.cpp.o: In function `IPC::Connection::createSyncMessageEncoder(IPC::StringReference, IPC::StringReference, unsigned long long, unsigned long long&)':
Connection.cpp:(.text+0x20f): undefined reference to `__atomic_fetch_add_8'
CMakeFiles/WebKit2.dir/UIProcess/StatisticsRequest.cpp.o: In function `WebKit::StatisticsRequest::addOutstandingRequest()':
StatisticsRequest.cpp:(.text+0xac3): undefined reference to `__atomic_fetch_add_8'
collect2: error: ld returned 1 exit status
make[2]: *** [lib/libwebkit2gtk-4.0.so.37.2.4] Error 1
make[1]: *** [Source/WebKit2/CMakeFiles/WebKit2.dir/all] Error 2
make: *** [all] Error 2
sasa at slack141-314:/tmp/DLG/logs/webkitgtk-2.6.3-2$ 

I have build without problems the same versions on my x86-64 machines. Both x86-64 and i686 have slackware-14.1 linux os. I tried also adding -latomic to the cxxflags but have not helped out.

Any comments appreciated.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141117/714d352b/attachment-0002.html>

More information about the webkit-unassigned mailing list