[Webkit-unassigned] [Bug 138661] New: Rename USE(MASM_PROBE) to ENABLE(MASM_PROBE)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 12 09:25:26 PST 2014


            Bug ID: 138661
           Summary: Rename USE(MASM_PROBE) to ENABLE(MASM_PROBE)
    Classification: Unclassified
           Product: WebKit
           Version: 528+ (Nightly build)
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

Also move the switch for enabling the use of MASM_PROBE from JavaScriptCore config.h to WTF's Platform.h.  This ensures that the setting is consistently applied even when building WebCore parts as well.

This is a step towards refactoring the probe mechanism to add printing functionality in JITted code for debugging

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141112/6ee6fc17/attachment-0002.html>

More information about the webkit-unassigned mailing list