[Webkit-unassigned] [Bug 138369] New: Rename checkMarkByte() to checkIfEitherInEdenGenOrAlreadyRemembered()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 4 13:36:47 PST 2014


            Bug ID: 138369
           Summary: Rename checkMarkByte() to
    Classification: Unclassified
           Product: WebKit
           Version: 528+ (Nightly build)
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

Write barriers are needed for GC Eden collections so that we can scan pointers pointing from old generation objects to eden generation objects.  The barrier currently checks the mark byte in a cell to see if the cell needs to be added to the GC remembered set.  The cell should only be added to the remembered set if:
1. If the cell is in the young generation.  It has no old to eden pointers by definition.
2. If the cell is already in the remembered set.

The barrier current names this check as checkMarkByte().  We should rename it to checkIfEitherInYoungGenOrAlreadyRemembered() to be clearer about its intent.

Similarly, Jump results of this check are currently named ownerNotMarkedOrAlreadyRemembered.  This can be misinterpreted as the owner is not marked or not already remembered.  We should rename it to ownerIsInEdenGenOrAlreadyRemembered which is clearer about what we're really checking for.  The cell being "not marked" implies that it is in the eden gen, which is what we really checking for anyway.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141104/013bf19d/attachment-0002.html>

More information about the webkit-unassigned mailing list