[Webkit-unassigned] [Bug 130081] [GTK] Use GMainLoopSource for idle and timeout sources in WebKit2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 28 06:51:10 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=130081


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #232121|review?                     |review+
               Flag|                            |




--- Comment #7 from Martin Robinson <mrobinson at webkit.org>  2014-05-28 06:51:32 PST ---
(From update of attachment 232121)
View in context: https://bugs.webkit.org/attachment.cgi?id=232121&action=review

Nice. Just consider fixing the small style nit and the source naming issue that we discussed earlier when landing.

> Source/WebKit2/Platform/gtk/WorkQueueGtk.cpp:89
> +        if (condition & G_IO_HUP || condition & G_IO_ERR || condition & G_IO_NVAL) {
> +            closeFunction();
> +            return GMainLoopSource::Stop;
> +        }

Nit: Maybe one more level of indentation here?

> Source/WebKit2/Platform/gtk/WorkQueueGtk.cpp:98
> +        }, socket.get(), G_IO_IN,

It might make this a little less strange.

--- Comment #8 from Martin Robinson <mrobinson at webkit.org>  2014-05-28 06:51:32 PST ---
(From update of attachment 232121)
View in context: https://bugs.webkit.org/attachment.cgi?id=232121&action=review

Nice. Just consider fixing the small style nit and the source naming issue that we discussed earlier when landing.

> Source/WebKit2/Platform/gtk/WorkQueueGtk.cpp:89
> +        if (condition & G_IO_HUP || condition & G_IO_ERR || condition & G_IO_NVAL) {
> +            closeFunction();
> +            return GMainLoopSource::Stop;
> +        }

Nit: Maybe one more level of indentation here?

> Source/WebKit2/Platform/gtk/WorkQueueGtk.cpp:98
> +        }, socket.get(), G_IO_IN,

It might make this a little less strange.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list